Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2026 - 08:00 UTC
Scheduled
To ensure continued platform stability and security, we are transitioning our recommended production guidelines regarding Lifecycle Management into an enforced policy.
Effective starting with this maintenance window, when a node drain is required, Allocated Gameservers (both Armada and Vessel-based) will be subject to eviction based on the following grace periods:
[1] LESS THAN 24 HOURS OLD Gameservers under 24 hours old will receive a shutdown hint set to the exact time when the server reaches 24 hours of age.
[2] MORE THAN 24 HOURS OLD Gameservers over 24 hours old will receive a shutdown hint set to the current time + 1 hour, giving the server a 1-hour grace period to exit gracefully.
[3] EVICTION PROCEDURES Once the shutdown hint time is reached, the gameserver will be evicted from the node via standard Agones shutdown procedures.
IMPORTANT NOTE: This policy does NOT introduce a general 24-hour lifetime limit for all gameservers. Gameservers will only be evicted if we actively need to drain a node (for example, to apply critical security updates or perform necessary reboots).
Posted Jun 18, 2026 - 09:48 UTC
This scheduled maintenance affected: Multiplayer Servers (Asia East, Asia Northeast, Asia Southeast, Australia Southeast, Europe West, US East, US Central, US West, South America East).