Widespread Connectivity Issues

Incident Report for GameFabric

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 18:00 UTC

Monitoring

The last interrupt was 20 minutes ago, we will continue to monitor the situation.
Posted Oct 31, 2025 - 12:02 UTC

Identified

We identified widespread connectivity issues across multiple region and providers, the individual connection issues are short however they repeat each one might be long enough to cause connection loss for players.
Posted Oct 31, 2025 - 11:31 UTC
This incident affected: Multiplayer Servers (Asia East, Asia Northeast, Asia Southeast, Australia Southeast, Europe West, US East, US Central, US West, South America East).