Database connectivity issues

Incident Report for GameFabric

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 07:26 UTC

Update

We will continue monitoring the situation but consider our systems to be operational currently.
The related google incident is https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 19:18 UTC

Monitoring

Google now also acknowledged the issues on their statuspage, so far the impact was limited to individual zones for us and with the multi zonal clusters it was possible to mitigate the immediate impact this incident has on the allocator instances.
We now see a 100% success rate on the allocator instances again.

See https://status.cloud.google.com/
Posted Jun 12, 2025 - 18:58 UTC

Investigating

We currently observe short interrupts of the connectivity to the database instances hosted within google.
We also noticed that google console + cli tools do not work properly as of right now so there might be a bigger issue with google cloud.

So far we only observed it in asia and us, this issue results in the allocator returning 5xx errors.
Posted Jun 12, 2025 - 18:30 UTC
This incident affected: Allocator (Asia, Europe, US).