Issues with Game Server Clusters in GCP using Spot Instances

Incident Report for GameFabric

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 17:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 13:52 UTC

Update

All cluster functionality in the impacted regions has been restored. We're continuing to monitor the situation.
Posted Nov 24, 2025 - 13:47 UTC

Update

Issues in us-central have been resolved
Posted Nov 24, 2025 - 13:38 UTC

Update

Issues in europe-west have been resolved
Posted Nov 24, 2025 - 13:22 UTC

Identified

We're currently experiencing capacity issues with cluster autoscaling on GCP for customers with clusters using Spot provisioning.
We're working on resolving the issues. Consequently, game servers might fail to launch, and observability data from these clusters can be delayed.
Posted Nov 24, 2025 - 13:21 UTC
This incident affected: Multiplayer Servers (Australia Southeast, Europe West, US Central).