Unexpected node churn in gcp cloud clusters

Incident Report for GameFabric

Resolved

A fixed version of the component was deployed.
Posted May 21, 2026 - 10:58 UTC

Identified

We identified a bug in one of our internal components that result in google cloud clusters getting unnecessary changes to nodepools.
This results in a rolling node replacement which will evict / restart ready gameservers.

Unless all ready gameservers are running on the same node no impact is to be expected by the node churn.
Posted May 20, 2026 - 15:53 UTC
This incident affected: Multiplayer Servers (Asia East, Asia Northeast, Asia Southeast, Australia Southeast, Europe West, US East, US Central, US West, South America East).