Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 18, 2026 - 06:00 UTC
Scheduled
We will be deploying a new version of GameFabric to all installations.
- Scope: Major UI overhaul (Beta), scaling improvements.
This release introduces the new Beta UI "Crossover Mode," allowing users to opt-in to a modernized interface while maintaining access to legacy features. We have also refined our scaling logic.
--- Added / New --- - Beta UI Crossover Mode: Introduced a global toggle that allows users to opt-in to the new Beta interface. When enabled, users can experience modernized overview pages for Armadas, ArmadaSets, Vessels, and Formations. - New Overview Pages: Launched comprehensive overview dashboards for ArmadaSets, Vessels, and Formations, featuring high-level KPIs and dense data tables for better fleet monitoring. - Terminate Game Server Modal: Added a new, design-aligned modal for terminating game servers directly from the overview pages.
--- Improved / Changed --- - Scaling Logic Refinement: Improved the user experience for scaling settings by allowing MinReplicas to be set to zero when a buffer is active, providing more flexibility for dynamic scaling. - UI Component Updates: Customized the DatePicker component to support "Since," "In Between," and "Before" filters, and integrated FontAwesome Pro for a more consistent visual experience. - Advanced Resource Options: To prevent accidental performance degradation, CPU Limits are now hidden behind an "Advanced Options" section by default. - Legacy Integration: Ensured seamless navigation between new Beta pages and legacy wizards to maintain workflow continuity. - Table Usability: Improved overview tables with global search, on-hover tooltips for dense content, and better resolution for spec-defined images.
--- Fixed --- - Scaling Accuracy: Fixed an issue where "Scale to Zero" metrics could show desired and ready numbers that diverged from reality. - Scale-to-Zero Panic Mode Behavior: Resolved a bug where "Panic Mode" was incorrectly triggered in specific configurations with three region types. - Security Validation: Improved security by ensuring URL and object scopes match during requests.
Posted May 12, 2026 - 09:44 UTC
This scheduled maintenance affected: Frontend & API.